Writing documents using the forrest format with XXE

Writing and editing documents

We will go through how we can make a document in XXE with this structure:

  • 1. heading1
  • 2. heading1
    • 1. heading2
      • 1. heading3
      • 2. heading3
    • 2. heading2
  • 3. heading1
Note
If you haven't installed XXE, we have written a howto explaning how it is done.

After that we will fill the document with paragraphs, lists, tables, adresses, etc.

Creating a forrest document

Open XXE. Choose File->New. In the resulting dialog you will see options for Forrest documents v1.x and v2.x. Choose "Document DTD v2.0" and press "OK".

You will have a sample document which consists of a title and a paragraph. Replace the title of the document with something you can live with:-), and delete the content of the paragraph below the title (Select with the mouse, and press delete).

Creating a document outline

On the bottom right side of the XXE-window there is a toolbar. Press the icon depicting a pen and paper. Put the cursor at the beginning of the first paragraph. After that press the "Replace"-tab. In the "Element"-list that appears choose "section". The result is a blue-green field with a red rectangle around where you write the title of the section (eg. "1. heading1").

After you have done this, you will see this line "document-body-section-title-#text" in the status line, just above the text view.

To make the next step of our outline, you will have to click the little red up-arrow on the top right of the XXE-window, until the status line shows "document-body-section". After that click the "Insert after"-tab, and choose "section". A new section will appear, on the same level as the first one. Fill in the title of this section, too (eg. "2. heading1").

To make the make the next step of our document, click the "Insert after"-tab, and choose "section" again. Fill in the title (eg. "1. heading2").

Repeat the step above to make the first 3rd level section. Fill in the title (eg. "1. heading3")

To make our second 3rd level heading, you will have to click the little red up-arrow on the top right untill the status field above the text shows "document-body-section-section-section". Now click the "Insert after"-tab again, and choose "section". Fill the title (eg. "2. heading3"

To make the second 2nd-level heading, we will have to click the little red up-arrow untill the status line says "document-body-section-section". Fill in the title.

To make the final 1st-level heading, press the little up-arrow untill the status field shows "document-body-section". Fill this title, too.

Inserting paragraphs and lists

To insert paragraphs after titles, you will have to go inside a section title, and click on the "Insert after"-tab. Choose "p", and fill in some text

If you want to insert a list, click the "Insert after"-tab, and choose "ul". If you want a nested list, click the "Insert"-tab and choose ul. To end the list, press the little red up-arrow untill the entire list is marked.

Text styles

Inside the main styles, it is possible to emphasize text using em and strong, mark it as code, and so on.

One way to do it is mark som text, and then click the "Convert [wrap]"-tab. Choose the tag you would like to convert the marked text to.

Inserting adresses

To insert an address, click the "Insert"-tag, and choose "a". Write the links text. To edit the link, click on the icon to the left of the pen and paper icon while inside the address tag. Replace the question marks in the value field.

Saving and opening documents

To save our newly created document, you can either press Command-S, the "save"-icon on the toolbar or choose File->Save from the menu. In the dialog that appears, choose the folder where you would like to save the document, and give it a name.

Open a document by either pressing Command-O, the "open"-icon in the toolbar or File->Open from the menu. Click your way to the desired document in the dialog.

Last modified: $Date: 2008-11-05 18:52:54 +0100 (Wed, 05 Nov 2008) $, by $Author: boerre $

by Børre Gaup