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Introduction to infovox4 

infovox4: accessibility anywhere, anytime! 

infovox4 is a USB product including a powerful SAPI text-to-speech engine and a quick and 

smart screenreader. It fits in your pocket and it guarantees that you are always ready to access 

any computer, anywhere, anytime. With infovox4 you are always ready to open and access any 

computer running Windows! 

infovox4 allows you to run the text-to-speech engine directly from the USB but also to install 

the product locally on up to three computers. After installing on a local computer you no longer 

need to have the USB inserted on the computer to access the infovox4 text-to-speech voices. 

infovox4 has two main functionalities: 

         Portable text-to-speech solution for your computers at home and at work. 

 

infovox4 can be installed locally on up to three computers, providing you with a 

powerful SAPI4 and SAPI5 compliant text-to-speech engine to be used on your 

computers together with your favourite screenreader. 

         Portable accessibility solution when travelling and when no other screenreaders are 

available. 

 

infovox4 lets you access any computer immediately with no need for any installation or 

administrator rights. It includes a wide choice of high quality text-to-speech voices, the 

brand new Colibri voices providing more flexibility and better performances a higher 

reading speed, a SpeechCreator application for listening to text and create sound files 

for personal usage, and the NVDA screen reader for accessing your computer. 

When you use infovox4 on your computer as a SAPI compatible Text-to-Speech engine, you can 

also choose to install the engine locally on the hard disk to increase the text-to-speech 

performance. 

infovox4 comes with lots of languages including several high quality voices. 

  



 

After plugging infovox4 into your computer, Windows will automatically 

map the USB device as two drives – infovox4 Launcher and infovox4 USB. 

The mapping is implemented by Windows, therefore, the mapping letters 

are selected by Windows. 

If you already have folders mapped in your computer, it may be happen 

that the automatic process maps infovox4 using a letter that is already 

used for another network drive. Follow these instructions if you 

encounter this problem: 

1.      Check which drive letters were used by infovox4. 

2.      Remove infovox4. 

3.      Specify another drive letter for the folder. Select a letter that is 

different from the ones used by infovox4. 

4.      Reboot your computer 

5.      Insert infovox4 into your computer 

Do not apply this solution if your computer’s physical units are involved, 

for instance hard-drive partitions. 

For network drive mapping instructions, please refer to the Windows 

Help. 

  

 

Depending on the BIOS settings of your computer, infovox4 can be 

recognized as a boot device. To avoid this risk it is recommended to 

remove the infovox4 USB device before rebooting the computer. 





infovox4 LaunchPad 

infovox4 LaunchPad is the main application that starts up automatically when the infovox4 USB 

pen drive is plugged into the computer. From this application, you can launch other infovox4 

applications and set parameters affecting the behaviour of infovox4. 

  

 

The LaunchPad main window 

  
The applications can be launched by clicking the button in the main window or by selecting 

corresponding items from the Tools menu. 

The LaunchPad's buttons 

Each of the applications included in the infovox4 suit are described in a separate chapter of this 

document. The following applications are included: 

         NVDA – the tool for reading the screen content out loud. 

         SpeechCreator – use this application to get a text played or for generating speech files. 

         Pronunciation Editor – the tool that allows you to change the standard word 

pronunciation. 



         Download Manager – the tool you need for managing the download, installation and 

update of the voices. 

         Voice Manager – allows you to create your own voices based on the ones included in 

infovox4 by setting different parameters. 

There are three more buttons in the infovox4 launcher apart from the application buttons. They 

are located in the lower part of the window. 

Configuration Wizard – Clicking this button opens a dialogue box were you may choose how you 

want to use infovox4 and decide if you want to run it from the USB unit or if you want to install 

the software locally. 

Eject/Exit – use this button to exit the LaunchPad. If you run the LaunchPad from the USB pen 

drive the infovox4 hardware unit will be ejected from the computer. You can then safely detach 

it from your computer. 

? - clicking this button opens the infovox4 Help 

The LaunchPad's menus 

Tools 

The Tools menu contains menu items that correspond to the buttons of the LaunchPad main 

window, see The LaunchPad’s buttons. 

Settings 

Use the commands available in this menu to customize your infovox4 and to manage it. 

The General sub-menu 

From the General sub-menu you can: 

         Change the localization language. 

         Manage the local infovox4 installation. This actions requires administrator privileges. 

         Select one of the options available for LaunchPad specifying the action on plugging the 

infovox4 stick to the computer. 

The Voice sub-menu 

From the Voice sub-menu you can: 

         Choose the infovox4 voice to be used with the Screenreader. You select your voice 

from the list of all the available voices. 

         Choose one of the voices you used recently. 

         Select one of the options available for the Screenreader specifying its behaviour on 

plugging in the infovox4 stick to the computer. 



         Activate or deactivate the playing back of the welcome message. 

         Launch the welcome message editor where you can enter the message to be spoken on 

starting the LaunchPad and select the voice speaking the welcome message. 

The PLI sub-menu 

PLI stands for Permanent Local Installation which means that you run infovox4 that has been 

installed locally on your computer. To work without the USB pen drive plugged into the 

computer, the PLI requires a license. Usually the required license is transferred automatically 

from the infovox4 pen drive when you install infovox4 but you can also transfer it from and to 

the infovox4 pen drive manually any time. The PLI menu allows you to manage the PLI license. 

You can do the following: 

         Transfer a PLI license to your computer. 

         Transfer back the PLI license from the computer to the infovox4 pen drive. 

         Check the PLI license status. The information presented specifies the number of 

available licenses and says if a PLI license is available on your computer. 

The Backup sub-menu 

The menu commands available here allows you to backup and restore your infovox4 USB unit. 

There are two options specifying the extent of your action in the dialogue box that these 

commands open. Complete covers the infovox4 software _and_ the user settings including user-

defined voices and user lexicons. The User data option affects only the user specific data. 

The SAPI sub-menu 

Here you can activate the SAPI engine. You can activate SAPI4, SAPI5 or both of them. The 

action requires administrator privileges. You don't need activate the SAPI if you install infovox4 

locally on your computer. It will be activated automatically. 

Help 

The Help menu gives you the following options: 

         Selecting the About sub-menu opens a dialog box displaying the information and the 

status of the infovox4. For instance, the serial number of your USB infovox4 unit is 

displayed. If you click the Copy to Clipboard button the information is copied to the 

Windows clipboard and the content can be pasted in a document or an email. This 

function can be useful for support purposes. 

         The License Agreement command displays the license terms that you need to accept in 

order to use the infovox4. 

         The Content command opens the infovox4 Help 

         Checking Automatic check for Updates on Launch makes the infovox4 LaunchPad check 

if there are any software updates available. If there are any updates you will be notified 

when the LaunchPad is launched. 



         Selecting Check for updates checks if there are any software updates available. You can 

run this command at any time. 





Download Manager 

The infovox4 Download Manager is an application that helps you to manage the infovox4 

voices. The main window displays the voices that you can use. 

  

 

The Download Manager main window 

For each voice there is a value specifying its name, language, technology, gender, installation 

status, version number and the selected action. 

The Technology field specifies one of the HQ, HD or Colibri values. 

         HQ: Very High Quality text-to-speech resulting in a very natural and pleasant-sounding 

voice suitable for reading longer texts, due to its more expressive character. Pitch and 

pitch dynamics are fixed and cannot be changed for HQ voices. 

         HD: High Density text-to-speech using an older technology that results in a more 

robotic and repetitive sentence melody. HD voices support changes of pitch and pitch 

dynamics. 

         Colibri: Colibri voices are very compact. They are based on the HQ voices with the same 

name. The sound quality is less natural but they enjoy higher flexibility, which makes 

these voices more suitable for reading short sentences or also longer texts at higher 

reading speed. Colibri voices support changes of pitch and pitch dynamics. 

Clicking the loudspeaker icon available for each of the voices will play a sample speech for the 

selected voice. 



Performing actions on the voice 

Your infovox4 license determines which voices are displayed in the voice list. You can access, 

manage and use these voices. The license type is displayed in the right bottom corner of the 

window. 

You can download voices using this application, install and uninstall them and also run the 

updates. The processing takes place in two steps. 

How to select actions on a voice? 

First you need to specify the action for a voice or several voices. You can choose between 

Install, Update, Uninstall, and None (no action to be performed). The choice can be performed 

in several ways. Choose the one that is most convenient for you. 

1.      Select a voice and use the context menu. When you right-click the mouse the options 

applicable for this voice will appear. Select the one you want. 

2.      Select a voice and use any of the buttons available at the lower section of the main 

window. The buttons that correspond to the actions not applicable to the selected voice 

will be disabled. Click one of the enabled buttons. 

3.      Select a voice and chose any of the available menu items. The actions that are not 

applicable to the selected voice will be disabled. You can access the menu commands 

using the arrow button or the Alt-command, i.e., pressing the Alt button + the letter 

affecting the menu item. 

4.      Double-click the field specifying the current action. The value will change to the next 

available. Consecutive double-clicking will change the value until you return to what 

was initially specified. 

After specifying the action a dialog box will appear asking you if you want to run the selected 

action immediately. If you click the Yes button the selected action is executed immediately. This 

is a good choice if you don’t plan to run more than the action you just selected. However, if you 

plan to run several actions it can be more convenient to save them as “pending actions” and 

execute all of them when you have finished selecting all your actions. If you prefer the second 

option click the No button. Tick the Do not ask again checkbox if you don’t want this dialog box 

to appear every time you select a new action. 

If you click the No button continue selecting actions for other voices. They all will be added to 

the “pending actions”. 

Click the Start actions button or select Start actions sub-menu from the File menu. 

It is also possible to select several voices using the Shift or the Ctrl buttons and choose an action 

available for all the selected voices. For instance if you want uninstall several voices you don't 

need to uninstall them one by one. Select all the voices you want to uninstall, select Uninstall, 

and click the Start actions button. 



If no actions are selected for the voices and there are voices requiring and update the caption of 

the Start actions button toggles to Update voice(s). If there are no selected actions and no voice 

update available, the button remains disabled (greyed). 

Changing the view 

You can affect the view of voices that are listed in the main window. You can control it by using 

the View menu or by the drop lists located immediately above the voice list. You can combine 

the filtering and sorting features to get the desired view. 

Filtering the voice view 

You can filter the voices listed in the main window by using the Filter by and Show sub-menus of 

the View menu or by selecting proper values in the corresponding drop lists located above the 

voice list. Start with selecting a filter option. You can filter the voices with respect to their 

language, gender or the installation status. After selecting the filtering value choose a Show 

value. The values available there depend on the filter option. 

Example: 

You want only the French voices to be displayed in your list. Select Language as the filter option 

in either the Filter by drop list or from the View menu, View→Filter by→Language. Now select 

French from the Show drop list or from the View menu, View→Show→French. After that, only 

French voices will be displayed in the voice list. 

Sorting the voices 

You can sort the order in which the voices are displayed by either clicking the column caption in 

the voice list or by selecting the View→Sort by menu and selecting any of the values available 

there. The action values are sorted in the ascending order by default. You can change it to 

descending order by clicking the arrow symbol displayed in the right part of the Action column 

header. 

The menus 

  

File 
Install Voice from File – use it if you have a local voice install file. 

Start actions – this command starts the actions selected for the 

voices, i.e., install, update, uninstall, or none (no action) 

Exit – run it to exit the Download Manager 

    

    

View 
The menu items available here are described in section Changing the 

view. 



    

    

Actions 
Get Info – this command displays an info box of a voice selected in 

the voice list. 

Play sample – this command plays a sample phrase of a voice 

selected in the voice list. 

Stop – stops the playback started by the Play sample command. 

The None, Install, Update, and Uninstall are described in Performing 

actions on the voice. 

    

    

Help 
infovox4 Download Manager Help – opens the Help 

About – this command opens an info box about the Download 

Manager 





SpeechCreator 

The SpeechCreator 

  

 

The SpeechCreator main window 

  
The infovox4 SpeechCreator shows some of the capabilities of the infovox4 Text-to-Speech 

Engine and has several typical features of a standard text-to-speech client application. The main 

functions of this application are listed here: 

         Reads out loud any text file or text directly typed in the SpeechCreator window, using 

anyone of the available infovox4 voices. 

         Possibility to convert text files into mp3 files. 

         Access the infovox4 Voice Manager and the Pronunciation Editor 

         Testing the SAPI tags 

In the SpeechCreator window you will see an empty document window. You can now type any 

text (or load a text file) and then have it played back by infovox4. 



The Menus 

The File menu 

         Use the New command to create a new text file. An empty document window appears, 

ready for editing. 

         Use the Open command to open a file. You will be prompted with the familiar Open File 

dialog box. Double-click on the name of the file that you want to open and its content 

will appear in a new document window. The file formats that SpeechCreator can open 

are the txt and rtf file formats. 

         Use the Save command to save files. To save the file with a different name, choose 

Save as. 

         Use the Exit command from to quit the SpeechCreator. 

The Edit menu 

         You can edit the text in the open document in the usual way, using the Undo, Redo, 

Cut, Copy, and Paste commands from the Edit menu. 

         Use the Select All command from the Edit menu to highlight the whole text in the 

active document window. 

         The command Toggle Focus to Toolbar moves the focus from the toolbar to the text 

window, if the toolbar is active. The focus is moved in the opposite direction if the text 

window is active. 

The Options menu 

         The Font... command is used to select a font type, size and style. The command starts a 

new window where the options can be selected. 

         If the Automatic Heading Detection option is selected the full stop will be automatically 

added to the text for each text line not terminated by the full stop. In this way the titles, 

itemized lists etc, will be read with correct intonation. 

For instance, a title not closed by the full stop will be read as a sentence if this option is 

selected. If this option is not selected, the title that is not closed by the full stop will not 

be considered as a separate sentence. It will be concatenated with the text that follows 

immediately after and it will constitute one sentence with the first sentence of the text 

that follows after the title. 

The option is activated by default. 

         The Use Tagged Text option determines how the text is interpreted. 

If you want to use the Microsoft Speech API control tags in your text, you have to select 

this option. 

Here is an example of tagged text: 

\Spd=100\ Now I speak normal, \Spd=150\ here I speak a bit 

faster, and soon I will \Spd=40\ speak very slowly! 



For more information on Text Tags see chapter Text Tags. 

The same result can be reached by checking the Use Tagged Text option box in the main 

window of the SpeechCreator. If this option is not selected, the Microsoft Speech API 

control tags will be interpreted as a plain text and read as such. 

         The Unicode Files option should be selected when the user opens a file that is a 

Unicode file. If this option is not selected the coding of the opened file will be 

interpreted as the default coding used by the voice that is currently active in the 

SpeechCreator.  

Another case where this option should be selected is when the user wants to save the 

text entered to the SpeechCreator edit window as a Unicode file. The default character 

coding is what is default for the particular voice. 

The Play Menu 

         Use the Play command from the Play menu to have the text in the edit window read 

out loud. The SpeechCreator automatically begins reading the text from the beginning 

of the file. If you only want to listen to a certain part of the text, highlight this part 

before you choose the Play command. 

         While the speech is in progress, you can choose the Stop command from the Play menu 

to stop the speech. You can also choose the Pause command from the Play menu to 

pause the speech. The speech output will continue when you click the Play button. 

You can also use hotkeys for the commands above: 

  

Play F2 

Pause F3 

Stop F4 

The Tools menu 

         Use the Pronunciation Editor command from the Tools menu to open the Pronunciation 

Editor. See chapter Pronunciation Editor for more information about this application.   

         Use the Voice Manager command from the Tools menu to open the infovox4 Voice 

Manager application. See section Voice Manager for more information on this 

application box. 

The Help menu 

         Use the Contents command from the Help menu or the hotkey F1 to open the Help file. 

         The About Speech Creator... command from the Help menu opens the About box 

containing information about SpeechCreator.  



Selecting a voice 

If you want to select a different voice to read the text in the current window, use the voice list 

on the right above the edit window. 

Creating speech files 

The SpeechCreator allows you to create speech files in the mp3 file format. 

  

 

Note: 

You may only use infovox4 or any sound file generated by the infovox4 

voices, for your own personal use. You may not use the sound files 

generated with the infovox4 voices in commercial applications, for public 

performances, for redistribution, or broadcasting. 

To see the infovox4 end-user license agreement open the infovox4 

LaunchPad, select Help→License Agreement.... 

You can convert any text opened in the SpeechCreator edit window to an mp3 speech file. 

Proceed as follows to generate a speech file: 

1.      Enter the text in the SpeechCreator edit window or open a text file that you wish to 

convert to speech. If you do not want to convert all the text in the edit window, simply 

select the text section to be used. 

2.      Select the voice from the voice list. 

3.      Check if the speech rate is set to the value you wish to use. 

4.      Listen to the text using the Play button. This will allow you to verify that the 

SpeechCreator settings are correct. 

5.      Start the conversion by selecting the Export as MP3... command from the File menu. 

This will launch a dialog box 

6.      Specify the output file name in the dialog box. 

7.      If you highlighted a specific text selection in the edit window check the Selected Text 

Only option box. Otherwise, all the text will be converted to a speech file. If no text is 

highlighted in the SpeechCreator edit window, this option will be dimmed. 

8.      The default bit rate of the mp3 file is 128. You can choose a different value from the Bit 

Rate drop-down list. 

9.      Clicking the Export button will start generating the mp3 speech file. 



Troubleshooter 

Error message at startup 

Should you receive an error message when launching the infovox4 SpeechCreator, this could be 

due to two common causes: 

         You do not have a valid license. 

         Your sound card is incorrectly configured. This is often the case when you use general 

audio drivers, often referred to as Soundblaster compatible. To use infovox4, you must 

have the correct driver matching the model of your sound card. The problem is that 

certain operations (like playing a WAV or MP3 file) usually can function with a general 

purpose driver, but other more specific audio operations, like those required by SAPI, 

requires the proper audio driver. 

No sound from the loudspeakers 

If you typed text in the document window and pressed Play, but do not hear any sound from 

the loudspeakers, please check the following: 

         that your loudspeakers are correctly connected; 

         that the volume in Windows is set to a proper level; 

         open the Tools menu and choose Voice Manager, and make sure that the speech 

volume is set to a proper level (note that the infovox4 volume corresponds to the WAVE 

volume controller in the Windows mixer); 





Voice Manager 

The Voice Manager is an application providing you with a way to customize the infovox4 voices. 

You choose an original voice among the available infovox4 voices and create a new voice based 

on the selected one. You customize your new voice by changing its settings. When you are 

pleased with your voice settings save the new customized voice. The voice based on an original 

voice and using your own settings is called a custom voice. Every application using infovox4 will 

then list your custom voice among the other available voices. 

You launch the Voice Manager from the infovox4 LaunchPad. It is also possible to launch it from 

the SpeechCreator. 

The Main Window 

  

 

The Voice Manager main window 

  
The Voice Manager's left pane lists your voices. The voice list is organised as a tree structure. In 

the remaining chapters, we will use a terminology common to that of tree structures to describe 

the items in the left pane: The term node indicates a generic point in the tree structure and the 

term branch indicates a node that is a sub-tree. You can click on the small "plus" or "minus" 

nodes to show or hide all branches and leaves below that node. 



Clicking a voice name in the voice list presents the corresponding voice information at the top of 

the right part. 

The lower part of the right section contains a text box that you can use for entering a text and 

playing it by the selected voice. This function is especially useful when you set parameters for 

your own voices. You can set a parameter and check how this setting affects the voice. Adjust 

the parameter again and check the effect by clicking the Play button. You can also use the Play 

command from the File menu or use the F2 key. While the text is played you can use F2 again to 

stop the playback. 

At the bottom of the Voice Manager main window you will find four buttons and a tick box. 

Their function is as follows: 

  

The '+' button Clicking it creates a new voice based on an 

original voice. The button is disabled if no voice 

has been selected from the voice list. The same 

action can be performed by running the New 

Custom Voice command from the File menu. 

The '-' button Clicking it removes the voice selected in the voice 

list. Only voices created by the user can be 

deleted. The button is disabled if no voice has 

been selected in the voice list or if the selected 

voice is an original voice and cannot be removed. 

The same action can be performed by running the 

Delete Custom Voice command from the File 

menu. 

The Sort by Language check 

box 

By default the voices are sorted alphabetically 

with respect to their names. Sometimes it can be 

more convenient to sort the voices according to 

their language. This will be the effect of ticking 

this check box. 

The Restore to default 

button 

Click this button to reset the voice you previously 

created. It means that all your settings will be 

deleted and replaced by the default values for 

each parameter. You can also run the Restore to 

Default command from the File menu. 

The Save button Clicking it saves the parameters you set for your 

voice. Also, you can run this command by using 

the Save Custom Voice command from the File 

menu. 



In the middle on the right the property box appears if a user-created voice is selected from the 

voice list. It is divided in several tabs where you can adjust all editable properties of a voice. For 

a complete description of the voice properties, please consult the Voice Properties section. 

Tutorials 

Follow these tutorials and you will learn how to perform the most common operations, like 

creating, editing and deleting a customized voice. 

In these tutorials we will use the terms custom voice to indicate the custom voice you are 

creating/editing or deleting, and original voice to refer to the infovox4 voice that you are using 

as a starting point for creating the new voice. 

Creating a Voice 

In this example we will create a new voice called Maggie based on the American English voice 

called Heather. The same procedure applies to all other infovox4 voices. 

Maggie will have a lighter tone, will speak a bit faster, but with longer pauses 

Do as follows: 

1.      Start the Voice Manager. 

2.      Look under the High Quality voices node, expand it if necessary. All installed voices are 

listed. 

3.      Click on the name of the voice you want to use as a template for the new voice. For our 

example we will use Heather22k. 

4.      Choose New Custom Voice from the File menu. The New Custom Voice dialogue box 

appears. 

5.      Type the name of the new voice in the Name of the new voice box. For this example we 

will use the name "Maggie". After typing the name click on Create to create the new 

voice. 

Now you can set the properties of the new voice. 

6.      Choose the General tab and set the Rate level using the Rate slider. For this example, 

choose 120. 

7.      Choose the Pauses tab and set the Punctuation level to Long. 

8.      Choose the Equalizer tab, activate the Use Filter check box, and set the equalizer to the 

following levels (from left to right): -1.0, -2.0, +2.0, +4.0. 

9.      Save the new voice by clicking on the Save button, or by choosing Save Custom Voice 

from the File menu. 



The new voice Maggie is now saved and listed right under Heather22k, ready to be used in any 

application using infovox4. 

Deleting a voice 

You can delete custom voices from the Voice Manager, but you cannot delete the original voices 

distributed with infovox4. 

Let us say that you want to delete the voice Maggie created in the previous sections, see 

section Creating a voice. 

Do as follows: 

1.      Start the Voice Manager. 

2.      Locate and select the voice you want to delete. For this example we will choose 

Maggie, located under the High Quality voices/Heather22k node. 

3.      Choose Delete Custom Voice from the File menu. 

A dialogue box appears asking you to confirm the choice of deleting the voice. 

4.      Click on Yes to proceed with the operation. 

The voice immediately disappears from the voices list. 

Editing a voice 

All custom voices can be edited. So, if we decide that the rate of the Maggie voice created in 

the previous tutorial (see section Creating a voice) is still too low, we can change that voice 

instead of creating a new one. 

Do as follows: 

1.      Start the Voice Manager. 

2.      Locate and select the voice you want to edit. For this example we choose Maggie, 

located under the High Quality Voices/Heather22k node. 

3.      Open the General tab and set the Rate level as you wish. You can play a text by typing it 

in the edit box at the bottom of the dialogue box to control the result of the new 

settings. Set any other setting as you wish. 

4.      Use the Undo command to reset the settings to the last saved ones, if you are unhappy 

with the changes you made. 

5.      When you are satisfied use the Save command to save the new settings. 

Voice Properties 

It is not possible to change the settings of the original voices, the ones that you get by installing 

infovox4. You can only adjust parameters for custom voices that you need to create yourself, 

see section Creating a voice for more information. When you have created your own voice, it is 



an exact copy of the original voice you used. To set speech parameters select the voice name in 

the voice list on the left. This action makes the voice property tabs dialog appearing in the right 

pane. Now you can change the characteristics of a voice, for example, the speech rate, the 

frequency settings, etc. You can experiment to make a voice more suited to your needs. 

  

 

Note: Not all of the parameters are available for all the voices. If one of the 

parameters specified below is not displayed for a particular voice it means 

that it is not supported for the selected voice. For instance the Pitch 

parameter is not supported for voices generated from the High Quality 

(HQ) voices. 

You can open the Properties tabs by clicking them, using the left/right arrow, or from the 

Customize menu. You can also use the following keyboard hotkeys: 

CTRL + F1 opens the General tab 

CTRL + F2 opens the Pause tab 

CTRL + F3 opens the Reading tab 

CTRL + F4 opens the Equalizer tab 

CTRL + F5 opens the Text Processing tab 

The voice property box is divided into five panes: 

  

General Contains settings for the speech rate and the volume. 

Pause Allows you to change the duration of each type of pause as 

specified in the tab. Select any of the values listed in the drop-

down list. You can also accept the default value which is set by the 

processing of the text and depends on the text content. 

Reading Reading specifies how the text is read. The default value is Normal 

which means regular reading. The remaining options will make 

your voice reading the text word by word or letter by letter. For 

the spelling and word mode, you can also modify the duration of 

the pause between each text unit. 

Note: The pause duration is not available for all voices in infovox4. 



Equalizer The equalizer allows you to change the acoustic appearance of a 

voice by changing four different frequency bands. 

When you select the Equalizer tab the equalizer is normally not 

selected and the frequency sliders are disabled. Click the Use Filter 

button to turn the equalizer on. Now you can drag the sliders to 

change the sound of the voice. Each slider corresponds to a 

specific frequency band, from low to high frequencies. 

There are four predefined equalizer pre-sets: bass booster, bass 

reducer, treble booster, and treble reducer. You can use them 

when you edit your voice. 

You can also define your own equalizer pre-sets that can be used 

by any voice. To create a pre-set, move the sliders until you have 

an equalizer setting that you want to use. Go to the combo box 

and type a name for the pre-set. Then click the Add button. 

Clicking the Remove button removes the selected equalizer pre-

set. 

The pre-set can now be called with help of the Equ tag. See Text 

Tags for more information. 

Text 

Processing 

Text can be processed by the text-to-speech system in two 

different ways. Advanced processing is the default setting. It 

means that the text is analysed and interpreted. For instance the 

pronunciation of numbers and abbreviations depends on the 

context. Details on text processing can be found in the Language 

Manual for each language. In some cases the user may wish to 

turn this processing off. To do so, uncheck the Verbose Mode tick 

box. 

Another setting available in this tab affects only the Arabic voices. 

Here you can decide how a non-Arabic text will be interpreted and 

which voice will read the non-Arabic text. You can choose between 

two languages: English and French. For both of them you can 

choose one of the available voices. The default option is None 

which means that a non-Arabic text will be read by the Arabic 

voice you use. 

You need to relaunch the Voice Manager before your changes 

affect the text processing. Click the Relaunch button to perform 

this action. When the Voice Manager is running again you can 

enter text and check how your new settings work. 



Menus and Functions 

The File Menu 

  

New Custom Voice, 

CTRL + N 

This command creates a new voice based on an 

original voice. Select an original voice from the voice 

list and execute this command. It opens a dialog box 

where you need to enter a name of your new voice. 

Click Create or press Enter. Afterwards your new voice 

will be added to the voice list under the original voice 

you used. 

Rename Custom Voice, 

CTRL + R 

You name your voice when you create it but it is 

possible to rename it later at any time. To do so, 

select the custom voice. Run this command from the 

File menu. Enter the new name and press Enter. 

Restore to Default This command resets your custom voice to the default 

settings. As a result, your custom voice will be a copy 

of the corresponding original voice. 

Listen to Info This plays the information about the selected voice. 

This information is displayed at the top of the main 

window's right section. 

Play, F2 Use this command to get your sample text played. 

While the text is played the command toggles to Stop 

and can be used for stopping the on-going play. 

Exit, CTRL + Q This command closes the Voice Manager application. 

The Customize Menu 

This menu can be used only for the custom voices. The actions you can perform from the 

Customize menu are the same as the ones you can do using the Properties tabs. Use the 

method that is more convenient for you. 

The menu items and the submenus you can choose correspond to the parameters that can be 

set for the voice. If an original voice is selected in the voice list this menu will be disabled. 

  

General You have four submenus available: Rate, Volume, Shaping, and 

Pitch. Selecting any of them will move you the General tab in 

Properties and put the focus on the corresponding slider. Use the 

left and right arrows to set the value. 



Pauses Use this menu for setting the pause length. In the first submenu 

you select the kind of pause to set. There are four pause types: 

Punctuation, Comma, Semicolon, and Brackets. In the second 

sub-menu you set the value. The available values are Default (i.e., 

set automatically by the text-to-speech system), Very Short, 

Short, Medium, Long and Very long. 

Reading It allows you to set the reading mode. In the first sub-menu you 

select between three available reading modes: Normal (regular 

reading), Word by Word, and Spelling. Use the Pause sub-menu 

to set the pause length between the read speech units. This 

affect only the Word by Word and the Spelling reading modes. 

The available values are Default (i.e., set automatically by the 

text-to-speech system), Very Short, Short, Medium, Long and 

Very long. 

Equalizer Activate the Equalizer by selecting On from the menu. Selecting 

Off will disable it. 

The Edit command can be used when the Equalizer is in the on 

state, otherwise this command is disabled. When you select the 

Edit command it will open the Equalizer tab with the focus on the 

first equalizer slider. Use the up and down arrows to set the 

value. Pressing the Tab moves the focus to next equalizer slider. 

Text 

Processing 

Here you can perform actions affecting the way in which the text 

is processed. 

Selecting the Verbose Mode command enables the infovox4 

component processing abbreviations and numbers. If this mode 

is not used, text will be read "as is", without any interpretation 

based on a context analysis. By default the Verbose Mode is 

enabled. 

The Language Detection commands affect only the Arabic voices. 

You set the language and the voice that will be used together 

with your Arabic voice for reading a non-Arabic text. 

Before your text processing setting takes effect you need to 

restart the Voice Manager. To do this, use the Re-launch 

command. 

Help 

  

Contents F1 It opens the infovox4 Help 



About Voice Manager This command opens the About box specifying some 

information about this version of Voice Manager. 





Pronunciation Editor 

A user lexicon allows you to change the standard pronunciation of a word. This is typically used 

to provide a correct pronunciation for acronyms that are not recognized by the text processor, 

or to correct or change the pronunciation of specific words, for instance, foreign words. 

  

 

The Pronunciation Editor main window 

  

How to use the Pronunciation Editor 

Pronunciation Lexicons 

Lexicons created by Pronunciation Editor are connected to a specific language. For instance, a 

lexicon created for American English will work for the American English voices and will not 

affect the British English voices, which require their own pronunciation lexicon. 

In the main window, you can choose what lexicon to work on by selecting a voice group from 

the Voice Group list. 

Adding a new lexicon entry 

If you want to change the way a word is pronounced by the voices of the same language, you 

need to add a proper entry to the pronunciation lexicon. First check to see whether the 

language displayed in the Voice Group is the one you would like to work with, then press the 

Add Word button. You can also use the menu Lexicon→Add Word or the shortcut Ctrl+A. 

In the Original Word field, type the word for which you want to change the pronunciation. The 

word is automatically displayed as a phonetic transcription in the Phonetic Transcription field if 

it is opened. By default, the Phonetic Transcription fields are not displayed, but you can easily 

disclose them with the appropriate disclosure button placed on the left of the Original Word 



field and the New Pronunciation field. You can also use the menu command View → Show 

Phonetic Transcriptions or its hotkey Ctrl+T. 

Enter the new pronunciation in the New Pronunciation field. This new pronunciation is also 

automatically displayed as phonetic transcription in the corresponding Phonetic Transcription 

field. 

You can specify the pronunciation in two ways. Firstly, by using phonetic symbols and secondly 

by rephrasing the word by using regular text. 

If you use phonetic symbols in your pronunciation you need to begin with the '#' character. 

Otherwise, your pronunciation will be considered as a regular text. If you specify your 

pronunciation using regular text (no phonetic symbols), you can use orthography, misspelling or 

rephrasing. Such transcriptions will be referred to as rephrasing. 

Using space or punctuation in rephrasing is not recommended. If you specify your pronunciation 

using more than one word it is recommended to store it as a phonetic transcription. This 

improves the speech quality. Storing the pronunciation as phonetic transcriptions is the default 

action. This signifies that even if you specify the pronunciation using regular text (without the 

use of phonetic symbols) your pronunciation will be converted to a phonetic string and saved as 

such in the lexicon. However, if you need to store the pronunciation that you specify as a 

rephrasing (i.e. not using phonetic symbols) uncheck Transcribe this phonetically. Unchecking it 

will store your transcriptions exactly as you specify them in the New Pronunciation box. 

Press the Update button to validate your new entry. 

Read Fine-tuning the new pronunciation section for more information about phonetic 

transcriptions. 

Updating an existing entry 

If you want to modify an existing entry of your pronunciation lexicon, select it in the list of 

lexicon entries. 

The original word and its phonetic transcription are shown in the Original Word field and the 

corresponding Phonetic Transcription field. The current pronunciation is shown in the New 

Pronunciation field. If the current pronunciation is specified as a regular text, its phonetic 

transcription is also shown in the corresponding Phonetic Transcription field. 

Make your modifications in the New Pronunciation field. The new pronunciation will be 

automatically displayed as a phonetic transcription in the corresponding Phonetic Transcription 

field. 

If the pronunciation is expressed as a phonetic transcription it must be preceded by the "#" 

character. 

Press the Update button to validate your new entry. 



Listening to the original word and the new pronunciation 

You have the possibility of listening to how the original word was pronounced by pressing the 

play button on the right of the Original Word field. You can also use the menu entry Lexicon → 

Play Original Word or the keyboard hotkey F2. 

You can also hear how the new transcription, that you typed in the New Pronunciation field is 

pronounced by pressing the play button on the right side of the field. You can also use the menu 

entry Lexicon → Play New Pronunciation or the keyboard shortcut Alt+F2. 

Deleting an entry 

Select the entry that you want to delete in the list of lexicon entries. Go to the menu Lexicon → 

Delete Word. You can also use the Delete Word button or the keyboard hotkey Ctrl+D. You can 

also press the delete key or the backspace key. 

Saving the lexicon 

None of the changes you make in the Pronunciation Editor are permanent and therefore, will 

not work in other applications unless you save your changes. To save all the changes and make 

them permanent, use the menu File → Save or the keyboard shortcut Ctrl+S. 

Using updated pronunciation lexicon with infovox4 voices 

Once you have saved the pronunciation lexicon, it will be used by the corresponding infovox4 

voices in all the Microsoft Speech API applications using them. However, if your voices are 

currently used, you will need to reboot the application using the infovox4 voices after having 

saved the lexicon. 

For instance, if you opened an application using the infovox4 US English voice Heather and 

afterwards, you made some changes in the pronunciation lexicon used by Heather, it will not 

affect Heather's pronunciation in running the application, even if the lexicon was saved. In order 

for Heather to apply your lexicon, you must quit and relaunch your application. Heather needs 

to be re-initialized. 

Changing the working voice 

When you work with a certain language, the Pronunciation Editor will use the first voice in the 

group as the default play voice. If the Voice Group contains several voices, you can set another 

voice as the voice used for reading the words and the word transcriptions. Select it in the menu 

Lexicon→Voices. 

The next time you open the voice group’s lexicon, the last selected voice will be used by default. 

Fine-tuning the new pronunciation 

The following section explains how to work efficiently with phonetic transcriptions, even 

without an expertise in linguistics. 

A description of the phonetic alphabet with examples of a particular language is available in the 

corresponding Language Manual (found in the Documentation folder on your infovox4 USB key). 



You can see the list of phonetic symbols by clicking the Show Phoneme List button or by 

selecting the command Show Phoneme List from the View menu. The corresponding keyboard 

hotkey is Ctrl+P 

Remember that the phonetic transcriptions you enter to the New Pronunciation field must start 

with the # character. 

Let's take as an example, Reading the name of a town in England and we will change its 

pronunciation for the US English voices. The standard pronunciation of this word is like 

"reeding", i.e. infovox4 considers this word being the 'ing' form of the verb read. If you enter the 

word Reading in the Original Word field it will show a phonetic transcription of the standard US 

English pronunciation applied by infovox4, i.e. "#r i1 d I N". You want this word to be 

pronounced like "#r E1 d I N", i.e. like the correct pronunciation of the town name in England. 

You can enter the complete phonetic transcription "#r E1 d I N" to the New Pronunciation field, 

but if you are not very familiar with the infovox4 phonetic alphabet you can try to use one of 

the methods described below: 

Method 1 

1.      Enter "Reading" in the Original Word field. The phonetic transcription "#r i1 d I N" is 

shown in the associated Phonetic Transcription field if it is shown. If it is not visible, click 

on the disclosure button marked up with the '+' sign. You can achieve the same result 

by selecting the menu command View → Show Phonetic Transcriptions or entering the 

keyboard hotkey Ctrl+T. 

2.      Press the down arrow button on the right of this Phonetic Transcription field. It will 

copy the phonetic text "#r i1 d I N"of the Original Word into the New Pronunciation 

field. You can also use the menu command Lexicon → Copy Word Transcription or the 

keyboard hotkey Ctr+K. 

3.      Look at the list of phonetic symbols for the phonetic symbol you need for your 

transcription. Open the list of phonetic symbols by clicking the Show Phoneme List. You 

can also use the menu command View → Show Phoneme List or the keyboard hotkey 

Ctr+P. 

The phonetic symbol you need is the /E/ occurring in words bet and recognition in the 

phoneme table. Replace the symbol /i/ in the New Pronunciation field by the /E/. 

Note the /1/ symbol which, as explained in the language manual, is used for lexical 

accent, i.e. the prominence (or emphasis) of a syllable in a word. 

4.      Press Update in order to add your new entry to the lexicon. 

Method 2 

1.      With this method you simply try to find the spelling that the standard pronunciation can 

be used for pronouncing the particular word you are working with. In our example, you 

will reach the requested result if you spell the town name like Redding. Enter the word 

Redding in the New Pronunciation field. The phonetic transcription "# r E1 d I N" is 

shown in the associated Phonetic Transcription field if it is shown. If it is not visible, click 



on the disclosure triangle to show it or use the menu command View → Show Phonetic 

Transcriptions. The keyboard hot key for this command is Ctrl+T 

2.      Press the up arrow button to the right of this Phonetic Transcription field. You can also 

use the menu command Lexicon → Copy Pronunciation Transcription or the keyboard 

shortcut Ctrl+Up arrow. This action will copy the phonetic string "#r E1 d I N" into the 

New Pronunciation field. 

3.      Press Update in order to add your new entry to the lexicon. 

Importing and exporting pronunciation lexicons 

Exporting 

You can convert your pronunciation lexicon to a text format (.txt) or save it in any location using 

the standard infovox4 lexicon format (.dic), i.e. you can export your lexicon. You export a lexicon 

using the menu command File → Export.... You can also use the keyboard hotkey Ctrl+Shift+X. 

Choose a filename and the location where to save the file and choose the file format. The 

default file format is text file (file extension: .txt). You can also choose the Acapela lexicon file 

binary format (file extension ".dic". Acapela Lexicon file format may be useful for backup 

purposes. You will not be able to export an Acapela lexicon binary format from one language to 

another language. 

The text format is tab separated which means that you have one entry per line and that the 

original word and new transcription are separated by the tabulation character. 

Importing 

If you have an access to a lexicon file that is a ".dic" file, i.e. it has Acapela's binary lexicon file 

format, you can add it to your infovox4 lexicon. You can also add lexicon entries of a text file if 

the text file is formatted according to the format described in the Exporting section. This action 

is called importing a file. 

Note that the file you import must contain entries of the language that is active in the 

Pronunciation Editor when you start this action. 

You can import entries in the current lexicon using the menu command File → Import .... You 

can also start this action using the keyboard hotkey Ctrl+I. This command will launch the Import 

lexicon dialog box. 

First, select the file containing the entries. You can import .dic files (Acapela Lexicon file binary 

format) and .txt files (tab separated text file). 

You will not be able to import an Acapela Lexicon binary format of one language group to a 

different language group. The text files should have the correct encoding. 



If there is a word in the lexicon to be imported that is already in your current lexicon, but 

containing a different transcription, a confirmation window will be opened by the application 

asking you about your decision on which entry to add to the infovox4 lexicon. 

Before the import starts a list of conflict entries will be displayed. For each item in the list you 

can select an action and decide which entry to use in the lexicon. 

Click Overwrite to replace the existing entry by the new one from the lexicon being imported. 

Press Keep to keep the existing pronunciation, i.e. you do not want to use the pronunciation 

from the imported file. 

You can also make your choice globally. Clicking Keep All will always keep the entries readily 

available in the lexicon and ensure that no entries that are already in the lexicon will be 

overwritten. If, in the case of a conflict, you always select an entry from the imported file you 

can simplify the process by clicking Overwrite All. 

The button Cancel Importing will cancel the import process and revert to the saved lexicon as it 

was before the lexicon import request. 

In the case of invalid phonetic entries in the imported text file, an error message is displayed. 

The invalid phonetic entries will not be added to the current lexicon. 

The Menus 

In this section the user will find a description of the menus available in the Pronunciation Editor 

application. 

File Menu 

The File Menu provides the standard file operations and functions for importing and exporting 

lexicons. 

Save (Ctrl+S) 

The Save command saves the lexicon. You need to run this command after updating your 

lexicon. The updates like adding new entries, deleting entries or changing the pronunciation will 

not affect your lexicon permanently before you save it. 

Import Lexicon (Ctrl+I) 

You can import lexicon entries from a text file or from another Acapela lexicon. The imported 

lexicon will be merged with the currently loaded lexicon. Make sure that the lexicon you are 

importing matches the language currently loaded, otherwise your import will fail. See section 

Importing for more information. 

Export Lexicon (Ctrl+Shift+X) 

Use this command for exporting your lexicon to a text file or to a lexicon using Acapela's 

standard lexicon format. See section Exporting for more information. 



Exit (Alt+F4, Ctrl+Q) 

This command terminates the Pronunciation Editor. 

Edit Menu 

This menu contains commands known from most Windows applications 

Undo (Ctrl+Z) 

This command reverses editing actions to return to the preceding state. 

Redo (Ctrl+Y) 

This command recreates editing actions that where undone by the Undo command. 

Cut (Ctrl+X) 

This command removes the selected text and stores it in the clipboard. 

Copy (Ctrl+C) 

This command places the selection in the clipboard. 

Paste (Ctrl+V) 

This command inserts the clipboard content at the cursor position. 

View Menu 

This menu contains commands affecting the information that is displayed by the Pronunciation 

Editor. 

Show Phonemes List (Ctrl+P) 

This command opens a window displaying the list of phonetic symbols used for specifying 

phonetic transcriptions. 

Show Phonetic Transcriptions (Ctrl+T) 

By default, no phonetic transcriptions are displayed when a new lexicon entry is created in the 

right pane on the Pronunciation Editor. In order to see how infovox4 would pronounce words 

select this command. After selecting, this menu item will toggle to Hide Phonetic Transcriptions 

with the same keyboard hot key. The same action can be performed by clicking the '+' button on 

the left of the Word and the Pronunciation fields. After clicking them the '+' sign will toggle to 

the '-' sign. 

Lexicon Menu 

This menu contains commands needed for updating the lexicon. 

Add Word (Ctrl+A) 

This command resets the edit fields and prepares the lexicon for a new entry. 



Delete Word (Ctrl+D, Delete, Backspace) 

This command deletes the selected entry from the lexicon. 

Delete All Words (Ctrl+Shift+D) 

This command deletes all the entries from the lexicon. As deleting all the entries cannot be 

undone the Pronunciation Editor launches a dialog box asking the user about confirming this 

action. 

Play Original Word (F2) 

This command plays the word currently entered to the Original Word field. 

Play New Pronunciation (Alt+F2) 

This command plays the word currently entered to the New Pronunciation field. 

Copy Word Transcription (Ctrl+K) 

This command copies the phonetic transcription from the Phonetic Transcription field to the 

New Pronunciation field. After the suggested phonetic string has been copied, the user can edit 

it in the New Pronunciation field. 

Copy Pronunciation Transcription (Ctrl+Up arrow) 

This command copies the phonetic string to the New Pronunciation field from the 

corresponding (placed right under) Phonetic Transcription field. 

Voice 

Use this menu command for selecting the standard voice used for all the Play actions of the 

Pronunciation Editor. This voice will be used for reading the Original Word and the New 

Pronunciation. 

Window Menu 

This menu contains only one menu item used for managing the Pronunciation Editor window. 

Minimize 

This command minimizes the Pronunciation Editor window. 

Help Menu 

The Help Menu gives you access to the help file, and to the Acapela Group home page on the 

Internet. 

Contents (F1) 

This command opens the Help file. 

About Pronunciation Editor... 



This command launches the About window.                

Language Manual 

This command opens the Language Manual of the language currently selected. 

                                                                                                                   





Text Tags 

infovox4 uses the Microsoft SAPI 4 tag pattern to read at runtime some specific information in 

the text. Sapi4 tags follow these general rules of syntax: 

         All tags begin and end with a backslash character ( \ ). 

         The backslash character is not allowed within a tag. 

         Tags are case-insensitive. For example, \RST\ is the same as \rst\ or \Rst\. 

         Tags are whitespace-dependent. For example, \Rst\ is not the same as \ Rst \. 

         To include a backslash character in tagged text, but outside a tag, use a double 

backslash ( \\ ). If a user wishes a filename to be read as c:\windows\system\test.txt, 

then the backslashes should be doubled, for example, c:\\windows\\system\\test.txt. 

         When the engine encounters a tag it does not understand, the tag is simply ignored 

(not read). 

         Tags are persistent from one text to another. For example, if the \spd=150\ is 

present in a text, all following texts will be read with a speed of 150 words per minute, 

until a reset tag is encountered or the language is changed. 

In the rest of the chapter you will find a list of tags supported by the infovox4. You can easily 

test the tags using the SpeechCreator, see chapter The SpeechCreator. 

Tags description 

\Pau=number\ 

This tag inserts a pause in the speech of the specified number of milliseconds. 

Example: 

I am \Pau=2000\ ready. 

A pause of 2 seconds is introduced after the word am. The maximum allowed pause length is 10 

seconds. 

\Prn="phonetic string"\ 

With this tag, a user can synthesize a specific pronunciation inside a text. The only allwed 

symbols are the one listed in the Phoneme List that can be opened from Pronunciation Editor. 

See chapter Pronunciation Editor for more information. This tag is only suitable for inserting 

single word into the text. Unpredictable errors (mainly prosody) can occur when inserting 

greater units. 

Example: 



I will say: \Prn=h @ l @U\ 

is equivalent to I will say: hello. 

  

 

Remark: This tag does not behave as in the standard SAPI 4 norm, since it 

does not automatically apply the same pronunciation for future words. 

\Spd=number\ 

This tag sets the baseline average talking speed of the voice to the specified number of words 

per minute. Each voice has a default speed (about 180 words per minute, depending of the 

voice). Use the \Rst\ tag to reset to the default speed. 

\Rst\ 

This tag resets the engine to the default settings for the current voice. 

\RmS=number\ 

Sets reading mode to spelling out each letter of each word (number=1), or turns it off 

(number=0). 

\RmW=number\ 

Sets reading mode to leaving audible pauses between each word (number=1), or turns it off 

(number=0). 

\Equ=Preset\ 

Change the equalizer preset at runtime. You can manage the list of presets with the Voice 

Manager, see chapter Voice Manager. 

\Vce=charact=value\ 

Where charact can be language or speaker. 

This tag changes the current speaker or language to the one specified by the value. Consider the 

following example: 

\vce=speaker=Sarah\ Hallo, ich heisse Sarah. 

\vce=speaker="Ryan"\ Hi, my name is Ryan. 

\vce=language="German"\ Hallo, ich spreche Deutch. 

\vce=language=American English\ Hi, I speak American English. 

No matter what voice was selected before, the first sentence will be spoken by Sarah. The 

second one will be spoken by Ryan. If the voice name specified as the value is not available the 

last valid voice setting will continue. The third sentence in the example will be spoken in 

German and the last one in American English. Again, the vce tags will work properly if the 

specified languages are available. Otherwise the last language setting will continue. 



As you can see in the example the quotation marks are optional for specifying the value. 


